Back
Resolved

Snapod Analytics / Application are Now Back Online

Started 16 Dec at 06:25am HST.

Snapod Application Snapod Analytics
Created

Snapod Analytics and Application were offline for quite a few days. This incident was caused by an SSL certificate issue which has now been fixed. All services are back online. We apologize for any inconvenience this may have caused. Have a great day!

Posted 16 Dec at 11:20am HST.